# CVE-2025-29906: Finit bundled getty can bypass /bin/login

> Finit's bundled getty allows unauthenticated login as any user, enabling privilege escalation and account takeover on affected Linux systems.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** DEBIAN-CVE-2025-29906, GHSA-563g-p98j-mc9q, UBUNTU-CVE-2025-29906

## What is CVE-2025-29906?

CVE-2025-29906 is a high-severity authentication bypass vulnerability in troglobit finit, published on 29 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Finit is a fast init for Linux systems. Versions starting from 3.0-rc1 and prior to version 4.11 bundle an implementation of getty for the `tty` configuration directive that can bypass `/bin/login`, i.e., a user can log in as any user without authentication. This issue has been patched in version 4.11.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-29906?


## How do I fix CVE-2025-29906?

Upgrade to a fixed version.

## Is CVE-2025-29906 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29906 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29906 and fix it if it is affected.

What it is: CVE-2025-29906 is a high-severity authentication bypass vulnerability in troglobit finit, published on 29 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29906 exists.

Affected product: troglobit finit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29906/ (Markdown: https://insights.sbomify.com/CVE-2025-29906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29906
- OSV: https://osv.dev/vulnerability/CVE-2025-29906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29906/
Summaries are generated and may contain mistakes; the official description above is the record.
