# CVE-2025-29907: jsPDF Bypass Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service via high CPU utilization by passing malicious data URLs to jsPDF image methods.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2025
- **Updated:** 18 Mar 2025
- **Also known as:** CLSA-2026-1773620203, GHSA-w532-jxjh-hjhj, ROOT-APP-NPM-CVE-2025-29907

## What is CVE-2025-29907?

CVE-2025-29907 is a high-severity denial of service vulnerability in parallax jsPDF, published on 18 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsPDF is a library to generate PDFs in JavaScript. Prior to 3.0.1, user control of the first argument of the addImage method results in CPU utilization and denial of service. If given the possibility to pass unsanitised image urls to the addImage method, a user can provide a harmful data-url that results in high CPU utilization and denial of service. Other affected methods are html and addSvgAsImage. The vulnerability was fixed in jsPDF 3.0.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-29907?

2 open source packages ship an affected version, including jspdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspdf` | npm | All versions | 3.0.1 |
| `jspdf` | npm | All versions | 3.0.1 |

Products: Parall Jspdf.

## How do I fix CVE-2025-29907?

Upgrade jspdf to 3.0.1 or later.

## Is CVE-2025-29907 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29907 exists.

## Other vulnerabilities in parallax jsPDF

- [CVE-2026-31938](https://insights.sbomify.com/CVE-2026-31938/): jsPDF has HTML Injection in New Window paths (critical 9.6)
- [CVE-2025-68428](https://insights.sbomify.com/CVE-2025-68428/): jsPDF has Local File Inclusion/Path Traversal vulnerability (critical 9.2)
- [CVE-2026-25535](https://insights.sbomify.com/CVE-2026-25535/): jsPDF Affected by Client-Side/Server-Side Denial of Service via Malicious GIF Dimensions (high 8.7)
- [CVE-2026-24133](https://insights.sbomify.com/CVE-2026-24133/): jsPDF Affected by Denial of Service (DoS) via Unvalidated BMP Dimensions in BMPDecoder (high 8.7)
- [CVE-2025-57810](https://insights.sbomify.com/CVE-2025-57810/): jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29907 and fix it if it is affected.

What it is: CVE-2025-29907 is a high-severity denial of service vulnerability in parallax jsPDF, published on 18 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29907 exists.

Affected packages and fixed versions:
- jspdf (npm): affected all versions; fixed in 3.0.1
- jspdf (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29907/ (Markdown: https://insights.sbomify.com/CVE-2025-29907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29907
- OSV: https://osv.dev/vulnerability/CVE-2025-29907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29907/
Summaries are generated and may contain mistakes; the official description above is the record.
