{"answers":{"affected":"2 open source packages ship an affected version, including io.netty.incubator:netty-incubator-codec-quic.","exploited":"There is no known exploitation of CVE-2025-29908 in the wild and no public exploit code.","fix":"Upgrade io.netty.incubator:netty-incubator-codec-quic to 0.0.71.Final or later.","what":"CVE-2025-29908 is a medium-severity denial of service vulnerability in netty-incubator-codec-quic, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29908 and fix it if it is affected.\n\nWhat it is: CVE-2025-29908 is a medium-severity denial of service vulnerability in netty-incubator-codec-quic, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-29908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.netty.incubator:netty-incubator-codec-quic (Maven): affected all versions; fixed in 0.0.71.Final\n- io.netty.incubator:netty-incubator-codec-quic (Maven): affected all versions; fixed in 0.0.71.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29908/ (Markdown: https://insights.sbomify.com/CVE-2025-29908/index.md)","id":"CVE-2025-29908","markdown":"https://insights.sbomify.com/CVE-2025-29908/index.md","name":"CVE-2025-29908","record":{"aliases":["GHSA-hqqc-jr88-p6x2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Netty QUIC codec","requires_auth":"none","summary":"Remote attackers can cause excessive CPU load on servers using the Netty QUIC codec by initiating connections with colliding Source Connection IDs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"Netty QUIC codec is a QUIC codec for netty which makes use of quiche. An issue was discovered in the codec. A hash collision vulnerability (in the hash map used to manage connections) allows remote attackers to cause a considerable CPU load on the server (a Hash DoS attack) by initiating connections with colliding Source Connection IDs (SCIDs). This vulnerability is fixed in 0.0.71.Final.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Netty QUIC hash collision DoS attack","id":"CVE-2025-29908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"CryptoLib's Crypto_TC_ApplySecurity() Has a Heap Buffer Overflow Vulnerability","id":"CVE-2025-29909"},"packages":[{"ecosystem":"Maven","fixed":["0.0.71.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty.incubator:netty-incubator-codec-quic","purl":null,"source":"GHSA-hqqc-jr88-p6x2"},{"ecosystem":"Maven","fixed":["0.0.71.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty.incubator:netty-incubator-codec-quic","purl":"pkg:maven/io.netty.incubator/netty-incubator-codec-quic","source":"GHSA-hqqc-jr88-p6x2"}],"prev":{"headline":"jsPDF Bypass Regular Expression Denial of Service (ReDoS)","id":"CVE-2025-29907"},"products":["netty-incubator-codec-quic"],"published":"2025-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-01","vendors":["netty"]},"summary":"Remote attackers can cause excessive CPU load on servers using the Netty QUIC codec by initiating connections with colliding Source Connection IDs.","url":"https://insights.sbomify.com/CVE-2025-29908/"}