# CVE-2025-29908: Netty QUIC hash collision DoS attack

> Remote attackers can cause excessive CPU load on servers using the Netty QUIC codec by initiating connections with colliding Source Connection IDs.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 1 Apr 2025
- **Also known as:** GHSA-hqqc-jr88-p6x2

## What is CVE-2025-29908?

CVE-2025-29908 is a medium-severity denial of service vulnerability in netty-incubator-codec-quic, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty QUIC codec is a QUIC codec for netty which makes use of quiche. An issue was discovered in the codec. A hash collision vulnerability (in the hash map used to manage connections) allows remote attackers to cause a considerable CPU load on the server (a Hash DoS attack) by initiating connections with colliding Source Connection IDs (SCIDs). This vulnerability is fixed in 0.0.71.Final.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-29908?

2 open source packages ship an affected version, including io.netty.incubator:netty-incubator-codec-quic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty.incubator:netty-incubator-codec-quic` | Maven | All versions | 0.0.71.Final |
| `io.netty.incubator:netty-incubator-codec-quic` | Maven | All versions | 0.0.71.Final |

## How do I fix CVE-2025-29908?

Upgrade io.netty.incubator:netty-incubator-codec-quic to 0.0.71.Final or later.

## Is CVE-2025-29908 being exploited?

There is no known exploitation of CVE-2025-29908 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29908 and fix it if it is affected.

What it is: CVE-2025-29908 is a medium-severity denial of service vulnerability in netty-incubator-codec-quic, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29908 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty.incubator:netty-incubator-codec-quic (Maven): affected all versions; fixed in 0.0.71.Final
- io.netty.incubator:netty-incubator-codec-quic (Maven): affected all versions; fixed in 0.0.71.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29908/ (Markdown: https://insights.sbomify.com/CVE-2025-29908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29908
- OSV: https://osv.dev/vulnerability/CVE-2025-29908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29908/
Summaries are generated and may contain mistakes; the official description above is the record.
