# CVE-2025-29914: OWASP Coraza WAF has parser confusion which leads to wrong URI in `REQUEST_FILENAME`

> Attackers can bypass WAF rules by crafting URIs with double slashes, causing incorrect filename parsing in OWASP Coraza.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-q9f5-625g-xm39, GO-2025-3537

## What is CVE-2025-29914?

CVE-2025-29914 is a medium-severity vulnerability in corazawaf coraza, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OWASP Coraza WAF is a golang modsecurity compatible web application firewall library. Prior to 3.3.3, if a request is made on an URI starting with //, coraza will set a wrong value in REQUEST_FILENAME. For example, if the URI //bar/uploads/foo.php?a=b is passed to coraza: , REQUEST_FILENAME will be set to /uploads/foo.php. This can lead to a rules bypass. This vulnerability is fixed in 3.3.3.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2025-29914?

8 open source packages ship an affected version, including github.com/corazawaf/coraza/v3, github.com/corazawaf/coraza and github.com/corazawaf/coraza/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/corazawaf/coraza/v3` | Go | All versions | 3.3.3 |
| `github.com/corazawaf/coraza/v3` | Go | All versions | 3.3.3 |
| `github.com/corazawaf/coraza/v3` | Go | All versions | 3.3.3 |
| `github.com/corazawaf/coraza` | Go | All versions | None |
| `github.com/corazawaf/coraza/v2` | Go | All versions | None |
| `github.com/jptosso/coraza-waf` | Go | All versions | None |
| `github.com/jptosso/coraza-waf` | Go | All versions | 3.3.3 |
| `github.com/jptosso/coraza-waf` | Go | All versions | 3.3.3 |

## How do I fix CVE-2025-29914?

Upgrade github.com/corazawaf/coraza/v3 to 3.3.3 or later.

## Is CVE-2025-29914 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29914 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29914 and fix it if it is affected.

What it is: CVE-2025-29914 is a medium-severity vulnerability in corazawaf coraza, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29914 exists.

Affected packages and fixed versions:
- github.com/corazawaf/coraza/v3 (Go): affected all versions; fixed in 3.3.3
- github.com/corazawaf/coraza/v3 (Go): affected all versions; fixed in 3.3.3
- github.com/corazawaf/coraza/v3 (Go): affected all versions; fixed in 3.3.3
- github.com/corazawaf/coraza (Go): affected all versions; no fix listed
- github.com/corazawaf/coraza/v2 (Go): affected all versions; no fix listed
- github.com/jptosso/coraza-waf (Go): affected all versions; no fix listed
- github.com/jptosso/coraza-waf (Go): affected all versions; fixed in 3.3.3
- github.com/jptosso/coraza-waf (Go): affected all versions; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29914/ (Markdown: https://insights.sbomify.com/CVE-2025-29914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29914
- OSV: https://osv.dev/vulnerability/CVE-2025-29914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29914/
Summaries are generated and may contain mistakes; the official description above is the record.
