# CVE-2025-29922: kcp allows unauthorized creation and deletion of objects in arbitrary workspaces through APIExport Virtual Workspace

> Attackers can create or delete objects in arbitrary workspaces without proper authorization, bypassing APIBinding requirements in kcp control planes.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-w2rr-38wv-8rrp, GO-2025-3538

## What is CVE-2025-29922?

CVE-2025-29922 is a critical missing authorization vulnerability in kcp-dev kcp, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

kcp is a Kubernetes-like control plane for form-factors and use-cases beyond Kubernetes and container workloads. Prior to 0.26.3, the identified vulnerability allows creating or deleting an object via the APIExport VirtualWorkspace in any arbitrary target workspace for pre-existing resources. By design, this should only be allowed when the workspace owner decides to give access to an API provider by creating an APIBinding. With this vulnerability, it is possible for an attacker to create and delete objects even if none of these requirements are satisfied, i.e. even if there is no APIBinding in that workspace at all or the workspace owner has created an APIBinding, but rejected a permission claim. A fix for this issue has been identified and has been published with kcp 0.26.3 and 0.27.0.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-29922?

3 open source packages ship an affected version, including github.com/kcp-dev/kcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.26.3 |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.26.3 |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.26.3 |

## How do I fix CVE-2025-29922?

Upgrade github.com/kcp-dev/kcp to 0.26.3 or later.

## Is CVE-2025-29922 being exploited?

There is no known exploitation of CVE-2025-29922 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29922 and fix it if it is affected.

What it is: CVE-2025-29922 is a critical missing authorization vulnerability in kcp-dev kcp, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29922 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.26.3
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.26.3
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.26.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29922/ (Markdown: https://insights.sbomify.com/CVE-2025-29922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29922
- OSV: https://osv.dev/vulnerability/CVE-2025-29922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29922/
Summaries are generated and may contain mistakes; the official description above is the record.
