CVE-2025-29924 XWiki uses the wrong wiki reference in AuthorizationManager
Attackers can access private information in subwikis via the REST API when specific view restrictions are enabled, bypassing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-29924?
CVE-2025-29924 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, it's possible for an user to get access to private information through the REST API - but could also be through another API - when a sub wiki is using "Prevent unregistered users to view pages". The vulnerability only affects subwikis, and it only concerns specific right options such as "Prevent unregistered users to view pages". or "Prevent unregistered users to edit pages". It's possible to detect the vulnerability by enabling "Prevent unregistered users to view pages" and then trying to access a page through the REST API without using any credentials. The vulnerability has been patched in XWiki 15.10.14, 16.4.6 and 16.10.0RC1.
Which versions are affected by CVE-2025-29924?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authorization-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 6.1-rc-1 | 15.10.14 |
org.xwiki.platform:xwiki-platform-security-authorization-api Maven | From 6.1-rc-1 | 15.10.14 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-29924?
Upgrade org.xwiki.platform:xwiki-platform-security-authorization-api to a fixed version for your release line: 16.4.6, 16.10.0-rc-1 or 15.10.14.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-29924 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29924 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-gq32-758c-3wm3.