# CVE-2025-29924: XWiki uses the wrong wiki reference in AuthorizationManager

> Attackers can access private information in subwikis via the REST API when specific view restrictions are enabled, bypassing authorization checks.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-gq32-758c-3wm3

## What is CVE-2025-29924?

CVE-2025-29924 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, it's possible for an user to get access to private information through the REST API - but could also be through another API - when a sub wiki is using "Prevent unregistered users to view pages". The vulnerability only affects subwikis, and it only concerns specific right options such as "Prevent unregistered users to view pages". or "Prevent unregistered users to edit pages". It's possible to detect the vulnerability by enabling "Prevent unregistered users to view pages" and then trying to access a page through the REST API without using any credentials. The vulnerability has been patched in XWiki 15.10.14, 16.4.6 and 16.10.0RC1.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-29924?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authorization-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 6.1-rc-1 | 15.10.14 |
| `org.xwiki.platform:xwiki-platform-security-authorization-api` | Maven | From 6.1-rc-1 | 15.10.14 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-29924?

Upgrade org.xwiki.platform:xwiki-platform-security-authorization-api to a fixed version for your release line: 16.4.6, 16.10.0-rc-1 or 15.10.14.

## Is CVE-2025-29924 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29924 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29924 and fix it if it is affected.

What it is: CVE-2025-29924 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29924 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 16.5.0-rc-1; fixed in 16.10.0-rc-1
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 16.5.0-rc-1; fixed in 16.10.0-rc-1
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 6.1-rc-1; fixed in 15.10.14
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): affected from 6.1-rc-1; fixed in 15.10.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29924/ (Markdown: https://insights.sbomify.com/CVE-2025-29924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29924
- OSV: https://osv.dev/vulnerability/CVE-2025-29924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29924/
Summaries are generated and may contain mistakes; the official description above is the record.
