CVE-2025-29926 The WikiManager REST API allows any user to create wikis

High 7.9 Published Updated

An attacker can create new wikis via the REST API to gain administrator privileges, requiring the optional WikiManager extension to be installed.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-29926?

CVE-2025-29926 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

XWiki Platform is a generic wiki platform. Prior to 15.10.15, 16.4.6, and 16.10.0, any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.

Weakness: CWE-862, CWE-285

Which versions are affected by CVE-2025-29926?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-wiki-rest-default. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 16.0.0-rc-116.4.6
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 16.0.0-rc-116.4.6
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 16.5.0-rc-116.10.0
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 16.5.0-rc-116.10.0
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 5.4-rc-115.10.15
org.xwiki.platform:xwiki-platform-wiki-rest-default MavenFrom 5.4-rc-115.10.15

Products include Xwiki Xwiki.

How do I fix CVE-2025-29926?

Upgrade org.xwiki.platform:xwiki-platform-wiki-rest-default to a fixed version for your release line: 16.4.6, 16.10.0 or 15.10.15.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-29926 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29926 exists.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-gfp2-6qhm-7x43.

Is CVE-2025-29926 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free