# CVE-2025-29926: The WikiManager REST API allows any user to create wikis

> An attacker can create new wikis via the REST API to gain administrator privileges, requiring the optional WikiManager extension to be installed.

- **Severity:** High 7.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-gfp2-6qhm-7x43

## What is CVE-2025-29926?

CVE-2025-29926 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Prior to 15.10.15, 16.4.6, and 16.10.0, any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-29926?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-wiki-rest-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 16.5.0-rc-1 | 16.10.0 |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 16.5.0-rc-1 | 16.10.0 |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 5.4-rc-1 | 15.10.15 |
| `org.xwiki.platform:xwiki-platform-wiki-rest-default` | Maven | From 5.4-rc-1 | 15.10.15 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-29926?

Upgrade org.xwiki.platform:xwiki-platform-wiki-rest-default to a fixed version for your release line: 16.4.6, 16.10.0 or 15.10.15.

## Is CVE-2025-29926 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29926 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29926 and fix it if it is affected.

What it is: CVE-2025-29926 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29926 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.0
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.0
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 5.4-rc-1; fixed in 15.10.15
- org.xwiki.platform:xwiki-platform-wiki-rest-default (Maven): affected from 5.4-rc-1; fixed in 15.10.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29926/ (Markdown: https://insights.sbomify.com/CVE-2025-29926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29926
- OSV: https://osv.dev/vulnerability/CVE-2025-29926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29926/
Summaries are generated and may contain mistakes; the official description above is the record.
