# CVE-2025-29927: Authorization Bypass in Next.js Middleware

> Attackers can bypass authorization checks in Next.js middleware by sending a specific header, allowing unauthorized access to protected resources.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-f82v-jwr5-mffw, MINI-fwhh-grf5-h64v, ROOT-APP-NPM-CVE-2025-29927

## What is CVE-2025-29927?

CVE-2025-29927 is a critical authentication bypass vulnerability in Vercel Next.js, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-29927?

8 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 12.0.0 | 12.3.5 |
| `next` | npm | From 12.0.0 | 12.3.5 |
| `next` | npm | From 13.0.0 | 13.5.9 |
| `next` | npm | From 13.0.0 | 13.5.9 |
| `next` | npm | From 14.0.0 | 14.2.25 |
| `next` | npm | From 14.0.0 | 14.2.25 |
| `next` | npm | From 15.0.0 | 15.2.3 |
| `next` | npm | From 15.0.0 | 15.2.3 |

Products: Vercel Next.js.

## How do I fix CVE-2025-29927?

Upgrade next to a fixed version for your release line: 12.3.5, 13.5.9, 14.2.25 or 15.2.3.

## Is CVE-2025-29927 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29927 exists.

Public exploit code:

- CVE-2025-29927 Proof of Concept (github_poc): https://github.com/aydinnyunus/CVE-2025-29927
- NextSploit is a command-line tool designed to detect and exploit CVE-2025-29927, a security flaw in Next.js (github_poc): https://github.com/AnonKryptiQuz/NextSploit
- Proof-of-Concept for Authorization Bypass in Next.js Middleware (github_poc): https://github.com/websecnl/CVE-2025-29927-PoC-Exploit
- A Nuclei template to detect CVE-2025-29927 the Next.js authentication bypass vulnerability (github_poc): https://github.com/6mile/nextjs-CVE-2025-29927
- Next.js PoC for CVE-2025-29927 (github_poc): https://github.com/azu/nextjs-cve-2025-29927-poc
- https://github.com/lirantal/vulnerable-nextjs-14-CVE-2025-29927 (github_poc): https://github.com/lirantal/vulnerable-nextjs-14-CVE-2025-29927

## Other vulnerabilities in Vercel Next.js

- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)
- [CVE-2026-64649](https://insights.sbomify.com/CVE-2026-64649/): Next.js: Server-Side Request Forgery in Server Actions on Custom Servers (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29927 and fix it if it is affected.

What it is: CVE-2025-29927 is a critical authentication bypass vulnerability in Vercel Next.js, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29927 exists.

Affected packages and fixed versions:
- next (npm): affected from 12.0.0; fixed in 12.3.5
- next (npm): affected from 12.0.0; fixed in 12.3.5
- next (npm): affected from 13.0.0; fixed in 13.5.9
- next (npm): affected from 13.0.0; fixed in 13.5.9
- next (npm): affected from 14.0.0; fixed in 14.2.25
- next (npm): affected from 14.0.0; fixed in 14.2.25
- next (npm): affected from 15.0.0; fixed in 15.2.3
- next (npm): affected from 15.0.0; fixed in 15.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29927/ (Markdown: https://insights.sbomify.com/CVE-2025-29927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29927
- OSV: https://osv.dev/vulnerability/CVE-2025-29927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29927/
Summaries are generated and may contain mistakes; the official description above is the record.
