CVE-2025-29953 Apache ActiveMQ NMS OpenWire Client: deserialization allowlist bypass

Critical 9.8 Published Updated

A deserialization allowlist bypass in the Apache ActiveMQ NMS OpenWire Client allows malicious servers to trigger arbitrary code execution on connecting clients.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-29953?

CVE-2025-29953 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS OpenWire Client, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Apache ActiveMQ NMS OpenWire Client.

This issue affects Apache ActiveMQ NMS OpenWire Client before 2.1.1 when performing connections to untrusted servers. Such servers could abuse the unbounded deserialization in the client to provide malicious responses that may eventually cause arbitrary code execution on the client. Version 2.1.0 introduced a allow/denylist feature to restrict deserialization, but this feature could be bypassed.

The .NET team has deprecated the built-in .NET binary serialization feature starting with .NET 9 and suggests migrating away from binary serialization. The project is considering to follow suit and drop this part of the NMS API altogether.

Users are recommended to upgrade to version 2.1.1, which fixes the issue. We also recommend to migrate away from relying on .NET binary serialization as a hardening method for the future.

Weakness: CWE-502

Which versions are affected by CVE-2025-29953?

2 open source packages ship an affected version, including Apache.NMS.ActiveMQ. It affects 1 product.

PackageAffectedFixed in
Apache.NMS.ActiveMQ NuGetAll versions2.1.1
Apache.NMS.ActiveMQ NuGetAll versions2.1.1

Products include Apache Activemq Nms Openwire.

How do I fix CVE-2025-29953?

Upgrade Apache.NMS.ActiveMQ to 2.1.1 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-29953 being exploited?

There is no known exploitation of CVE-2025-29953 in the wild and no public exploit code.

Sources

Also known as GHSA-9g64-r942-fvmp.

Is CVE-2025-29953 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free