{"answers":{"affected":"2 open source packages ship an affected version, including Apache.NMS.ActiveMQ. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-29953 in the wild and no public exploit code.","fix":"Upgrade Apache.NMS.ActiveMQ to 2.1.1 or later.","what":"CVE-2025-29953 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS OpenWire Client, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29953 and fix it if it is affected.\n\nWhat it is: CVE-2025-29953 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS OpenWire Client, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-29953 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Apache.NMS.ActiveMQ (NuGet): affected all versions; fixed in 2.1.1\n- Apache.NMS.ActiveMQ (NuGet): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29953/ (Markdown: https://insights.sbomify.com/CVE-2025-29953/index.md)","id":"CVE-2025-29953","markdown":"https://insights.sbomify.com/CVE-2025-29953/index.md","name":"CVE-2025-29953","record":{"aliases":["GHSA-9g64-r942-fvmp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ActiveMQ NMS Client","requires_auth":"none","summary":"A deserialization allowlist bypass in the Apache ActiveMQ NMS OpenWire Client allows malicious servers to trigger arbitrary code execution on connecting clients.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq_nms_openwire","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of Untrusted Data vulnerability in Apache ActiveMQ NMS OpenWire Client.\n\nThis issue affects Apache ActiveMQ NMS OpenWire Client before 2.1.1 when performing connections to untrusted servers. Such servers could abuse the unbounded deserialization in the client to provide malicious responses that may eventually cause arbitrary code execution on the client. Version 2.1.0 introduced a allow/denylist feature to restrict deserialization, but this feature could be bypassed.\n\nThe .NET team has deprecated the built-in .NET binary serialization feature starting with .NET 9 and suggests migrating away from binary serialization. The project is considering to follow suit and drop this part of the NMS API altogether.\n\nUsers are recommended to upgrade to version 2.1.1, which fixes the issue. We also recommend to migrate away from relying on .NET binary serialization as a hardening method for the future.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ActiveMQ NMS OpenWire Client: deserialization allowlist bypass","id":"CVE-2025-29953","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Windows Lightweight Directory Access Protocol (LDAP) Denial of Service Vulnerability","id":"CVE-2025-29954"},"packages":[{"ecosystem":"NuGet","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"Apache.NMS.ActiveMQ","purl":null,"source":"GHSA-9g64-r942-fvmp"},{"ecosystem":"NuGet","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"Apache.NMS.ActiveMQ","purl":"pkg:nuget/Apache.NMS.ActiveMQ","source":"GHSA-9g64-r942-fvmp"}],"prev":{"headline":"Memory corruption in AMD EPYC™ 9005 Series Processors","id":"CVE-2025-29952"},"products":["Apache ActiveMQ NMS OpenWire Client"],"published":"2025-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Apache Software Foundation"]},"summary":"A deserialization allowlist bypass in the Apache ActiveMQ NMS OpenWire Client allows malicious servers to trigger arbitrary code execution on connecting clients.","url":"https://insights.sbomify.com/CVE-2025-29953/"}