# CVE-2025-29953: Apache ActiveMQ NMS OpenWire Client: deserialization allowlist bypass

> A deserialization allowlist bypass in the Apache ActiveMQ NMS OpenWire Client allows malicious servers to trigger arbitrary code execution on connecting clients.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-9g64-r942-fvmp

## What is CVE-2025-29953?

CVE-2025-29953 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS OpenWire Client, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache ActiveMQ NMS OpenWire Client.

This issue affects Apache ActiveMQ NMS OpenWire Client before 2.1.1 when performing connections to untrusted servers. Such servers could abuse the unbounded deserialization in the client to provide malicious responses that may eventually cause arbitrary code execution on the client. Version 2.1.0 introduced a allow/denylist feature to restrict deserialization, but this feature could be bypassed.

The .NET team has deprecated the built-in .NET binary serialization feature starting with .NET 9 and suggests migrating away from binary serialization. The project is considering to follow suit and drop this part of the NMS API altogether.

Users are recommended to upgrade to version 2.1.1, which fixes the issue. We also recommend to migrate away from relying on .NET binary serialization as a hardening method for the future.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-29953?

2 open source packages ship an affected version, including Apache.NMS.ActiveMQ. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Apache.NMS.ActiveMQ` | NuGet | All versions | 2.1.1 |
| `Apache.NMS.ActiveMQ` | NuGet | All versions | 2.1.1 |

Products: Apache Activemq Nms Openwire.

## How do I fix CVE-2025-29953?

Upgrade Apache.NMS.ActiveMQ to 2.1.1 or later.

## Is CVE-2025-29953 being exploited?

There is no known exploitation of CVE-2025-29953 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29953 and fix it if it is affected.

What it is: CVE-2025-29953 is a critical unsafe deserialization vulnerability in Apache ActiveMQ NMS OpenWire Client, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29953 in the wild and no public exploit code.

Affected packages and fixed versions:
- Apache.NMS.ActiveMQ (NuGet): affected all versions; fixed in 2.1.1
- Apache.NMS.ActiveMQ (NuGet): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29953/ (Markdown: https://insights.sbomify.com/CVE-2025-29953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29953
- OSV: https://osv.dev/vulnerability/CVE-2025-29953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29953/
Summaries are generated and may contain mistakes; the official description above is the record.
