CVE-2025-2998 PyTorch torch.nn.utils.rnn.pad_packed_sequence memory corruption

Medium 4.8 Published Updated

A local attacker can exploit memory corruption in PyTorch's pad_packed_sequence function to potentially execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2998?

CVE-2025-2998 is a medium-severity memory corruption vulnerability in PyTorch, published on 31 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in PyTorch 2.6.0. It has been declared as critical. Affected by this vulnerability is the function torch.nn.utils.rnn.pad_packed_sequence. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119

Which versions are affected by CVE-2025-2998?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.

PackageAffectedFixed in
pytorch BitnamiFrom 2.6.02.7.0
torch PyPIAll versions to 2.6.0None
torch PyPIAll versions to 2.6.0None
torch PyPIAll versions to 2.6.0-NANone

Products include Linuxfoundation Pytorch.

How do I fix CVE-2025-2998?

Upgrade pytorch to 2.7.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-2998 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2998 exists.

Sources

Also known as BIT-pytorch-2025-2998, DEBIAN-CVE-2025-2998, ECHO-a3a3-45a6-10ed, GHSA-f4hp-rmr7-r7v8, PYSEC-2025-192, UBUNTU-CVE-2025-2998.

Is CVE-2025-2998 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free