# CVE-2025-2998: PyTorch torch.nn.utils.rnn.pad_packed_sequence memory corruption

> A local attacker can exploit memory corruption in PyTorch's pad_packed_sequence function to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 31 Mar 2025
- **Also known as:** BIT-pytorch-2025-2998, DEBIAN-CVE-2025-2998, ECHO-a3a3-45a6-10ed, GHSA-f4hp-rmr7-r7v8, PYSEC-2025-192, UBUNTU-CVE-2025-2998

## What is CVE-2025-2998?

CVE-2025-2998 is a medium-severity memory corruption vulnerability in PyTorch, published on 31 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in PyTorch 2.6.0. It has been declared as critical. Affected by this vulnerability is the function torch.nn.utils.rnn.pad_packed_sequence. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-2998?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | From 2.6.0 | 2.7.0 |
| `torch` | PyPI | All versions to 2.6.0 | None |
| `torch` | PyPI | All versions to 2.6.0 | None |
| `torch` | PyPI | All versions to 2.6.0-NA | None |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-2998?

Upgrade pytorch to 2.7.0 or later.

## Is CVE-2025-2998 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2998 exists.

## Other vulnerabilities in PyTorch

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2998 and fix it if it is affected.

What it is: CVE-2025-2998 is a medium-severity memory corruption vulnerability in PyTorch, published on 31 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2998 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected from 2.6.0; fixed in 2.7.0
- torch (PyPI): affected all versions up to 2.6.0; no fix listed
- torch (PyPI): affected all versions up to 2.6.0; no fix listed
- torch (PyPI): affected all versions up to 2.6.0-NA; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2998/ (Markdown: https://insights.sbomify.com/CVE-2025-2998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2998
- OSV: https://osv.dev/vulnerability/CVE-2025-2998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2998/
Summaries are generated and may contain mistakes; the official description above is the record.
