CVE-2025-2999 PyTorch torch.nn.utils.rnn.unpack_sequence memory corruption

Medium 4.8 Published Updated

A local attacker can exploit memory corruption in PyTorch's unpack_sequence function to potentially execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2999?

CVE-2025-2999 is a medium-severity memory corruption vulnerability in PyTorch, published on 31 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in PyTorch 2.6.0. It has been rated as critical. Affected by this issue is the function torch.nn.utils.rnn.unpack_sequence. The manipulation leads to memory corruption. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119

Which versions are affected by CVE-2025-2999?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.

PackageAffectedFixed in
pytorch BitnamiFrom 2.6.02.7.0
torch PyPIAll versions to 2.6.0-NANone
torch PyPIAll versions2.9.1
torch PyPIAll versions2.9.1

Products include Linuxfoundation Pytorch.

How do I fix CVE-2025-2999?

Upgrade pytorch to 2.7.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-2999 being exploited?

There is no known exploitation of CVE-2025-2999 in the wild and no public exploit code.

Sources

Also known as BIT-pytorch-2025-2999, DEBIAN-CVE-2025-2999, ECHO-27c7-eea0-603b, GHSA-vgrw-7cvw-pwgx, PYSEC-2025-193, UBUNTU-CVE-2025-2999.

Is CVE-2025-2999 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free