CVE-2025-30001 Apache StreamPark: Authenticated users can trigger remote command execution

High 7.3 Published Updated

Authenticated users can exploit incorrect permissions to execute arbitrary commands on the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-30001?

CVE-2025-30001 is a high-severity vulnerability in Apache StreamPark, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Incorrect Execution-Assigned Permissions vulnerability in Apache StreamPark.

This issue affects Apache StreamPark: from 2.1.4 before 2.1.6.

Users are recommended to upgrade to version 2.1.6, which fixes the issue.

Weakness: CWE-279

Which versions are affected by CVE-2025-30001?

2 open source packages ship an affected version, including org.apache.streampark:streampark. It affects 1 product.

PackageAffectedFixed in
org.apache.streampark:streampark MavenAll versions to 2.1.5None
org.apache.streampark:streampark MavenAll versions to 2.1.5None

Products include Apache Streampark.

How do I fix CVE-2025-30001?

No fix has been published for CVE-2025-30001 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-30001 being exploited?

There is no known exploitation of CVE-2025-30001 in the wild and no public exploit code.

Sources

Also known as GHSA-6wwv-6mm3-pp76.

Is CVE-2025-30001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free