CVE-2025-3001 PyTorch torch.lstm_cell memory corruption

Medium 4.8 Published Updated

A local attacker can exploit memory corruption in PyTorch's LSTM cell function to potentially execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3001?

CVE-2025-3001 is a medium-severity memory corruption vulnerability in PyTorch, published on 31 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability classified as critical was found in PyTorch 2.6.0. This vulnerability affects the function torch.lstm_cell. The manipulation leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119

Which versions are affected by CVE-2025-3001?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.

PackageAffectedFixed in
pytorch BitnamiFrom 2.6.02.7.0
torch PyPIAll versions to 2.6.0-NANone
torch PyPIAll versions2.10.0
torch PyPIAll versions2.10.0

Products include Linuxfoundation Pytorch.

How do I fix CVE-2025-3001?

Upgrade pytorch to 2.7.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-3001 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3001 exists.

Sources

Also known as AZL-73178, AZL-73180, BIT-pytorch-2025-3001, DEBIAN-CVE-2025-3001, ECHO-5f91-e3ce-0c45, GHSA-qfhq-4f3w-5fph and 2 more.

Is CVE-2025-3001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free