CVE-2025-30065 Apache Parquet Avro Module Vulnerable to Arbitrary Code Execution

Critical 10.0 Published Updated

Attackers can execute arbitrary code by providing a malicious Avro schema in Parquet file metadata, affecting users of the parquet-avro module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30065?

CVE-2025-30065 is a critical unsafe deserialization vulnerability in Apache Parquet Java, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code

Users are recommended to upgrade to version 1.15.1, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2025-30065?

2 open source packages ship an affected version, including org.apache.parquet:parquet-avro. It affects 1 product.

PackageAffectedFixed in
org.apache.parquet:parquet-avro MavenAll versions1.15.1
org.apache.parquet:parquet-avro MavenAll versions1.15.1

Products include Apache Parquet Java.

How do I fix CVE-2025-30065?

Upgrade org.apache.parquet:parquet-avro to 1.15.1 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-30065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30065 exists.

Public exploit code: 7 proofs of concept on GitHub.

Sources

Also known as GHSA-2c59-37c4-qrx5.

Is CVE-2025-30065 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free