# CVE-2025-30065: Apache Parquet Avro Module Vulnerable to Arbitrary Code Execution

> Attackers can execute arbitrary code by providing a malicious Avro schema in Parquet file metadata, affecting users of the parquet-avro module.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-2c59-37c4-qrx5

## What is CVE-2025-30065?

CVE-2025-30065 is a critical unsafe deserialization vulnerability in Apache Parquet Java, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code

Users are recommended to upgrade to version 1.15.1, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-30065?

2 open source packages ship an affected version, including org.apache.parquet:parquet-avro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.parquet:parquet-avro` | Maven | All versions | 1.15.1 |
| `org.apache.parquet:parquet-avro` | Maven | All versions | 1.15.1 |

Products: Apache Parquet Java.

## How do I fix CVE-2025-30065?

Upgrade org.apache.parquet:parquet-avro to 1.15.1 or later.

## Is CVE-2025-30065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30065 exists.

Public exploit code:

- PoC (github_poc): https://github.com/bjornhels/CVE-2025-30065
- https://github.com/F5-Labs/parquet-canary-exploit-rce-poc-CVE-2025-30065 (github_poc): https://github.com/F5-Labs/parquet-canary-exploit-rce-poc-CVE-2025-30065
- This PoC targets CVE-2025-30065, an RCE vulnerability in Apache Parquet via Avro schema deserialization. It abuses the getDefaultValue() mechanism to instantiate arbitrary record types during parsing, enabling code execution when untrusted data is processed without proper controls. (github_poc): https://github.com/h3st4k3r/CVE-2025-30065
- https://github.com/mouadk/parquet-rce-poc-CVE-2025-30065 (github_poc): https://github.com/mouadk/parquet-rce-poc-CVE-2025-30065
- A CVSS 10.0-rated vulnerability in the parquet-avro Java module allows remote code execution via unsafe deserialization when parsing schemas. Tracked as CVE-2025-30065, this flaw affects Apache Parquet ≤ 1.15.0. All users must upgrade to version 1.15.1 immediately to mitigate exploitation risks. (github_poc): https://github.com/ThreatRadarAI/TRAI-001-Critical-RCE-Vulnerability-in-Apache-Parquet-CVE-2025-30065-Simulation
- CVE-2025-30065 PoC (github_poc): https://github.com/ron-imperva/CVE-2025-30065-PoC

## Other vulnerabilities in Apache Parquet Java

- [CVE-2021-41561](https://insights.sbomify.com/CVE-2021-41561/): Apache Parquet-MR potential DoS in case of malicious Parquet file (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30065 and fix it if it is affected.

What it is: CVE-2025-30065 is a critical unsafe deserialization vulnerability in Apache Parquet Java, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30065 exists.

Affected packages and fixed versions:
- org.apache.parquet:parquet-avro (Maven): affected all versions; fixed in 1.15.1
- org.apache.parquet:parquet-avro (Maven): affected all versions; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30065/ (Markdown: https://insights.sbomify.com/CVE-2025-30065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30065
- OSV: https://osv.dev/vulnerability/CVE-2025-30065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30065/
Summaries are generated and may contain mistakes; the official description above is the record.
