CVE-2025-30067 Apache Kylin: The remote code execution via jdbc url

High 7.2 Published Updated

An attacker with admin privileges can inject malicious JDBC URLs to execute arbitrary code on the server.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30067?

CVE-2025-30067 is a high-severity code injection vulnerability in Apache Kylin, published on 27 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.1.

Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

Weakness: CWE-94

Which versions are affected by CVE-2025-30067?

2 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.

PackageAffectedFixed in
org.apache.kylin:kylin MavenFrom 4.0.05.0.2
org.apache.kylin:kylin MavenFrom 4.0.05.0.2

Products include Apache Kylin.

How do I fix CVE-2025-30067?

Upgrade org.apache.kylin:kylin to 5.0.2 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-30067 being exploited?

There is no known exploitation of CVE-2025-30067 in the wild and no public exploit code.

Sources

Also known as GHSA-29m8-wh9p-5wc4.

Is CVE-2025-30067 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free