{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-30067 in the wild and no public exploit code.","fix":"Upgrade org.apache.kylin:kylin to 5.0.2 or later.","what":"CVE-2025-30067 is a high-severity code injection vulnerability in Apache Kylin, published on 27 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30067 and fix it if it is affected.\n\nWhat it is: CVE-2025-30067 is a high-severity code injection vulnerability in Apache Kylin, published on 27 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-30067 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.2\n- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30067/ (Markdown: https://insights.sbomify.com/CVE-2025-30067/index.md)","id":"CVE-2025-30067","markdown":"https://insights.sbomify.com/CVE-2025-30067/index.md","name":"CVE-2025-30067","record":{"aliases":["GHSA-29m8-wh9p-5wc4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Kylin analytics","requires_auth":"high_privilege","summary":"An attacker with admin privileges can inject malicious JDBC URLs to execute arbitrary code on the server.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kylin","vendor":"apache"}],"cvss":{"score":7.2,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. \nIf an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.\n\nThis issue affects Apache Kylin: from 4.0.0 through 5.0.1.\n\nUsers are recommended to upgrade to version 5.0.2 or above, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Kylin: The remote code execution via jdbc url","id":"CVE-2025-30067","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Auth bypass in n/a","id":"CVE-2025-30072"},"packages":[{"ecosystem":"Maven","fixed":["5.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":null,"source":"GHSA-29m8-wh9p-5wc4"},{"ecosystem":"Maven","fixed":["5.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":"pkg:maven/org.apache.kylin/kylin","source":"GHSA-29m8-wh9p-5wc4"}],"prev":{"headline":"tj-actions/changed-files GitHub Action Embedded Malicious Code","id":"CVE-2025-30066"},"products":["Apache Kylin"],"published":"2025-03-27","related":[{"cvss_score":8.8,"headline":"Apache Kylin OS Command Injection","id":"CVE-2020-1956","kev_date_added":"2022-03-25","published":"2020-05-22"},{"cvss_score":9.8,"headline":"Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API","id":"CVE-2026-62390","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":9.8,"headline":"Apache Kylin: Command injection by Diagnosis Controller","id":"CVE-2022-44621","kev_date_added":null,"published":"2022-12-30"},{"cvss_score":9.8,"headline":"Apache Kylin vulnerable to remote code execution","id":"CVE-2022-24697","kev_date_added":null,"published":"2022-10-13"},{"cvss_score":9.8,"headline":"Apache Kylin unsafe class loading","id":"CVE-2021-31522","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command injection","id":"CVE-2021-45456","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command Injection in Kylin","id":"CVE-2020-13925","kev_date_added":null,"published":"2020-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["Apache Software Foundation"]},"summary":"An attacker with admin privileges can inject malicious JDBC URLs to execute arbitrary code on the server.","url":"https://insights.sbomify.com/CVE-2025-30067/"}