# CVE-2025-30067: Apache Kylin: The remote code execution via jdbc url

> An attacker with admin privileges can inject malicious JDBC URLs to execute arbitrary code on the server.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-29m8-wh9p-5wc4

## What is CVE-2025-30067?

CVE-2025-30067 is a high-severity code injection vulnerability in Apache Kylin, published on 27 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. 
If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.1.

Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-30067?

2 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 5.0.2 |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 5.0.2 |

Products: Apache Kylin.

## How do I fix CVE-2025-30067?

Upgrade org.apache.kylin:kylin to 5.0.2 or later.

## Is CVE-2025-30067 being exploited?

There is no known exploitation of CVE-2025-30067 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30067 and fix it if it is affected.

What it is: CVE-2025-30067 is a high-severity code injection vulnerability in Apache Kylin, published on 27 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30067 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.2
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30067/ (Markdown: https://insights.sbomify.com/CVE-2025-30067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30067
- OSV: https://osv.dev/vulnerability/CVE-2025-30067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30067/
Summaries are generated and may contain mistakes; the official description above is the record.
