# CVE-2025-30095: Hardcoded credentials in VyOS

> Attackers can perform man-in-the-middle attacks on SSH connections because VyOS and similar systems ship with identical Dropbear host keys.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Mar 2025
- **Updated:** 21 Apr 2025
- **Also known as:** GHSA-8vh6-m67f-4h33

## What is CVE-2025-30095?

CVE-2025-30095 is a critical vulnerability in VyOS, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

VyOS 1.3 through 1.5 (fixed in 1.4.2) or any Debian-based system using dropbear in combination with live-build has the same Dropbear private host keys across different installations. Thus, an attacker can conduct active man-in-the-middle attacks against SSH connections if Dropbear is enabled as the SSH daemon. I n VyOS, this is not the default configuration for the system SSH daemon, but is for the console service. To mitigate this, one can run "rm -f /etc/dropbear/*key*" and/or "rm -f /etc/dropbear-initramfs/*key*" and then dropbearkey -t rsa -s 4096 -f /etc/dropbear_rsa_host_key and reload the service or reboot the system before using Dropbear as the SSH daemon (this clears out all keys mistakenly built into the release image) or update to the latest version of VyOS 1.4 or 1.5. Note that this vulnerability is not unique to VyOS and may appear in any Debian-based Linux distribution that uses Dropbear in combination with live-build, which has a safeguard against this behavior in OpenSSH but no equivalent one for Dropbear.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2025-30095?


## How do I fix CVE-2025-30095?

No fix has been published for CVE-2025-30095 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-30095 being exploited?

There is no known exploitation of CVE-2025-30095 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30095 and fix it if it is affected.

What it is: CVE-2025-30095 is a critical vulnerability in VyOS, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30095 in the wild and no public exploit code.

Affected product: VyOS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30095/ (Markdown: https://insights.sbomify.com/CVE-2025-30095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30095
- OSV: https://osv.dev/vulnerability/CVE-2025-30095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30095/
Summaries are generated and may contain mistakes; the official description above is the record.
