{"answers":{"affected":"2 open source packages ship an affected version, including fast-jwt.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30144 exists.","fix":"Upgrade fast-jwt to 5.0.6 or later.","what":"CVE-2025-30144 is a medium-severity authentication bypass vulnerability in nearform fast-jwt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30144 and fix it if it is affected.\n\nWhat it is: CVE-2025-30144 is a medium-severity authentication bypass vulnerability in nearform fast-jwt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30144 exists.\n\nAffected packages and fixed versions:\n- fast-jwt (npm): affected all versions; fixed in 5.0.6\n- fast-jwt (npm): affected all versions; fixed in 5.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30144/ (Markdown: https://insights.sbomify.com/CVE-2025-30144/index.md)","id":"CVE-2025-30144","markdown":"https://insights.sbomify.com/CVE-2025-30144/index.md","name":"CVE-2025-30144","record":{"aliases":["GHSA-gm45-q3v2-6cf8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JWT library","requires_auth":"none","summary":"Attackers can bypass JWT issuer validation by crafting tokens with array-based iss claims, allowing forged tokens to be accepted by vulnerable applications.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 5.0.6, the fast-jwt library does not properly validate the iss claim based on the RFC 7519. The iss (issuer) claim validation within the fast-jwt library permits an array of strings as a valid iss value. This design flaw enables a potential attack where a malicious actor crafts a JWT with an iss claim structured as ['https://attacker-domain/', 'https://valid-iss']. Due to the permissive validation, the JWT will be deemed valid. Furthermore, if the application relies on external libraries like get-jwks that do not independently validate the iss claim, the attacker can leverage this vulnerability to forge a JWT that will be accepted by the victim application. Essentially, the attacker can insert their own domain into the iss array, alongside the legitimate issuer, and bypass the intended security checks. This issue is fixed in 5.0.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-03-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-03-21T18:48:28Z","kind":"github_poc","ref":"https://github.com/tibrn/CVE-2025-30144","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"Fast-JWT Improperly Validates iss Claims","id":"CVE-2025-30144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"GeoServer has an Infinite Loop Vulnerability in Jiffle process","id":"CVE-2025-30145"},"packages":[{"ecosystem":"npm","fixed":["5.0.6"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":null,"source":"GHSA-gm45-q3v2-6cf8"},{"ecosystem":"npm","fixed":["5.0.6"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":"pkg:npm/fast-jwt","source":"GHSA-gm45-q3v2-6cf8"}],"prev":{"headline":"Cross-site scripting in App \u0026 API Protector","id":"CVE-2025-30143"},"products":["fast-jwt"],"published":"2025-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["nearform"]},"summary":"Attackers can bypass JWT issuer validation by crafting tokens with array-based iss claims, allowing forged tokens to be accepted by vulnerable applications.","url":"https://insights.sbomify.com/CVE-2025-30144/"}