# CVE-2025-30144: Fast-JWT Improperly Validates iss Claims

> Attackers can bypass JWT issuer validation by crafting tokens with array-based iss claims, allowing forged tokens to be accepted by vulnerable applications.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-gm45-q3v2-6cf8

## What is CVE-2025-30144?

CVE-2025-30144 is a medium-severity authentication bypass vulnerability in nearform fast-jwt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 5.0.6, the fast-jwt library does not properly validate the iss claim based on the RFC 7519. The iss (issuer) claim validation within the fast-jwt library permits an array of strings as a valid iss value. This design flaw enables a potential attack where a malicious actor crafts a JWT with an iss claim structured as ['https://attacker-domain/', 'https://valid-iss']. Due to the permissive validation, the JWT will be deemed valid. Furthermore, if the application relies on external libraries like get-jwks that do not independently validate the iss claim, the attacker can leverage this vulnerability to forge a JWT that will be accepted by the victim application. Essentially, the attacker can insert their own domain into the iss array, alongside the legitimate issuer, and bypass the intended security checks. This issue is fixed in 5.0.6.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-30144?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | All versions | 5.0.6 |
| `fast-jwt` | npm | All versions | 5.0.6 |

## How do I fix CVE-2025-30144?

Upgrade fast-jwt to 5.0.6 or later.

## Is CVE-2025-30144 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30144 exists.

Public exploit code:

- https://github.com/tibrn/CVE-2025-30144 (github_poc): https://github.com/tibrn/CVE-2025-30144

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30144 and fix it if it is affected.

What it is: CVE-2025-30144 is a medium-severity authentication bypass vulnerability in nearform fast-jwt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30144 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected all versions; fixed in 5.0.6
- fast-jwt (npm): affected all versions; fixed in 5.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30144/ (Markdown: https://insights.sbomify.com/CVE-2025-30144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30144
- OSV: https://osv.dev/vulnerability/CVE-2025-30144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30144/
Summaries are generated and may contain mistakes; the official description above is the record.
