# CVE-2025-30150: Shopware 6 allows attackers to check for registered accounts through the store-api

> Attackers can enumerate registered user accounts via the store-api recovery endpoint, exposing customer email existence.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-hh7j-6x3q-f52h

## What is CVE-2025-30150?

CVE-2025-30150 is a medium-severity vulnerability in Shopware Shopware, published on 8 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Through the store-api it is possible as a attacker to check if a specific e-mail address has an account in the shop. Using the store-api endpoint /store-api/account/recovery-password you get the response, which indicates clearly that there is no account for this customer. In contrast you get a success response if the account was found. This vulnerability is fixed in Shopware 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2025-30150?

12 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.5.8.18 |
| `shopware/core` | Packagist | All versions | 6.5.8.18 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/core` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/core` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/platform` | Packagist | All versions | 6.5.8.18 |
| `shopware/platform` | Packagist | All versions | 6.5.8.18 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/platform` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/platform` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |

Products: Shopware Shopware.

## How do I fix CVE-2025-30150?

Upgrade shopware/core to a fixed version for your release line: 6.5.8.18, 6.6.10.3 or 6.7.0.0-rc2.

## Is CVE-2025-30150 being exploited?

There is no known exploitation of CVE-2025-30150 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30150 and fix it if it is affected.

What it is: CVE-2025-30150 is a medium-severity vulnerability in Shopware Shopware, published on 8 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30150 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/core (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/core (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/platform (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/platform (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30150/ (Markdown: https://insights.sbomify.com/CVE-2025-30150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30150
- OSV: https://osv.dev/vulnerability/CVE-2025-30150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30150/
Summaries are generated and may contain mistakes; the official description above is the record.
