# CVE-2025-30152: Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout

> Attackers can manipulate cart contents after PayPal authorization, causing merchants to ship goods without receiving full payment.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-hxg4-65p5-9w37

## What is CVE-2025-30152?

CVE-2025-30152 is a medium-severity vulnerability in Sylius PayPalPlugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. Prior to 1.6.2, 1.7.2, and 2.0.2, a discovered vulnerability allows users to modify their shopping cart after completing the PayPal Checkout process and payment authorization. If a user initiates a PayPal transaction from a product page or the cart page and then returns to the order summary page, they can still manipulate the cart contents before finalizing the order. As a result, the order amount in Sylius may be higher than the amount actually captured by PayPal, leading to a scenario where merchants deliver products or services without full payment. The issue is fixed in versions: 1.6.2, 1.7.2, 2.0.2 and above.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter)

## Which versions are affected by CVE-2025-30152?

6 open source packages ship an affected version, including sylius/paypal-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/paypal-plugin` | Packagist | All versions | 1.6.2 |
| `sylius/paypal-plugin` | Packagist | All versions | 1.6.2 |
| `sylius/paypal-plugin` | Packagist | From 1.7.0 | 1.7.2 |
| `sylius/paypal-plugin` | Packagist | From 1.7.0 | 1.7.2 |
| `sylius/paypal-plugin` | Packagist | From 2.0.0 | 2.0.2 |
| `sylius/paypal-plugin` | Packagist | From 2.0.0 | 2.0.2 |

## How do I fix CVE-2025-30152?

Upgrade sylius/paypal-plugin to a fixed version for your release line: 1.6.2, 1.7.2 or 2.0.2.

## Is CVE-2025-30152 being exploited?

There is no known exploitation of CVE-2025-30152 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30152 and fix it if it is affected.

What it is: CVE-2025-30152 is a medium-severity vulnerability in Sylius PayPalPlugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-30152 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/paypal-plugin (Packagist): affected all versions; fixed in 1.6.2
- sylius/paypal-plugin (Packagist): affected all versions; fixed in 1.6.2
- sylius/paypal-plugin (Packagist): affected from 1.7.0; fixed in 1.7.2
- sylius/paypal-plugin (Packagist): affected from 1.7.0; fixed in 1.7.2
- sylius/paypal-plugin (Packagist): affected from 2.0.0; fixed in 2.0.2
- sylius/paypal-plugin (Packagist): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30152/ (Markdown: https://insights.sbomify.com/CVE-2025-30152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30152
- OSV: https://osv.dev/vulnerability/CVE-2025-30152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30152/
Summaries are generated and may contain mistakes; the official description above is the record.
