{"answers":{"affected":"3 open source packages ship an affected version, including github.com/getkin/kin-openapi.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30153 exists.","fix":"Upgrade github.com/getkin/kin-openapi to 0.131.0 or later.","what":"CVE-2025-30153 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30153 and fix it if it is affected.\n\nWhat it is: CVE-2025-30153 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30153 exists.\n\nAffected packages and fixed versions:\n- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0\n- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0\n- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30153/ (Markdown: https://insights.sbomify.com/CVE-2025-30153/index.md)","id":"CVE-2025-30153","markdown":"https://insights.sbomify.com/CVE-2025-30153/index.md","name":"CVE-2025-30153","record":{"aliases":["CLEANSTART-2026-WF39253","CLEANSTART-2026-XI97972","DEBIAN-CVE-2025-30153","GHSA-wq9g-9vfc-cfq9","GO-2025-3533","MINI-j5h2-f9hg-6wwg","MINI-r5c2-525w-h9p4","MINI-x8xf-p454-2jjp","MINI-xvq3-8wg4-mgjr","UBUNTU-CVE-2025-30153","openSUSE-SU-2026:10922-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go OpenAPI library","requires_auth":"none","summary":"An attacker can cause a denial of service by uploading a crafted ZIP bomb to a server using the kin-openapi library for request validation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"kin-openapi is a Go project for handling OpenAPI files. Prior to 0.131.0, when validating a request with a multipart/form-data schema, if the OpenAPI schema allows it, an attacker can upload a crafted ZIP file (e.g., a ZIP bomb), causing the server to consume all available system memory. The root cause comes from the ZipFileBodyDecoder, which is registered automatically by the module (contrary to what the documentation says). This vulnerability is fixed in 0.131.0.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Handling of Highly Compressed Data (Data Amplification) in github.com/getkin/kin-openapi/openapi3filter","id":"CVE-2025-30153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":5,"next":{"headline":"reviewdog/action-setup GitHub Action Embedded Malicious Code","id":"CVE-2025-30154"},"packages":[{"ecosystem":"Go","fixed":["0.131.0"],"introduced":["0"],"last_affected":[],"package":"github.com/getkin/kin-openapi","purl":null,"source":"GHSA-wq9g-9vfc-cfq9"},{"ecosystem":"Go","fixed":["0.131.0"],"introduced":["0"],"last_affected":[],"package":"github.com/getkin/kin-openapi","purl":"pkg:golang/github.com/getkin/kin-openapi","source":"GHSA-wq9g-9vfc-cfq9"},{"ecosystem":"Go","fixed":["0.131.0"],"introduced":["0"],"last_affected":[],"package":"github.com/getkin/kin-openapi","purl":"pkg:golang/github.com/getkin/kin-openapi","source":"GO-2025-3533"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["11.6.14+security01-4.1"],"introduced":["0"],"last_affected":[],"package":"grafana","purl":"pkg:rpm/opensuse/grafana\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10922-1"}],"prev":{"headline":"Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout","id":"CVE-2025-30152"},"products":["kin-openapi"],"published":"2025-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["getkin"]},"summary":"An attacker can cause a denial of service by uploading a crafted ZIP bomb to a server using the kin-openapi library for request validation.","url":"https://insights.sbomify.com/CVE-2025-30153/"}