# CVE-2025-30153: Improper Handling of Highly Compressed Data (Data Amplification) in github.com/getkin/kin-openapi/openapi3filter

> An attacker can cause a denial of service by uploading a crafted ZIP bomb to a server using the kin-openapi library for request validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** CLEANSTART-2026-WF39253, CLEANSTART-2026-XI97972, DEBIAN-CVE-2025-30153, GHSA-wq9g-9vfc-cfq9, GO-2025-3533, MINI-j5h2-f9hg-6wwg, MINI-r5c2-525w-h9p4, MINI-x8xf-p454-2jjp, MINI-xvq3-8wg4-mgjr, UBUNTU-CVE-2025-30153, openSUSE-SU-2026:10922-1

## What is CVE-2025-30153?

CVE-2025-30153 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. Prior to 0.131.0, when validating a request with a multipart/form-data schema, if the OpenAPI schema allows it, an attacker can upload a crafted ZIP file (e.g., a ZIP bomb), causing the server to consume all available system memory. The root cause comes from the ZipFileBodyDecoder, which is registered automatically by the module (contrary to what the documentation says). This vulnerability is fixed in 0.131.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2025-30153?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.131.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.131.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.131.0 |
| `grafana` | openSUSE:Tumbleweed | All versions | 11.6.14+security01-4.1 |

## How do I fix CVE-2025-30153?

Upgrade github.com/getkin/kin-openapi to 0.131.0 or later.

## Is CVE-2025-30153 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30153 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30153 and fix it if it is affected.

What it is: CVE-2025-30153 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30153 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.131.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30153/ (Markdown: https://insights.sbomify.com/CVE-2025-30153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30153
- OSV: https://osv.dev/vulnerability/CVE-2025-30153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30153/
Summaries are generated and may contain mistakes; the official description above is the record.
