CVE-2025-30157 Envoy crashes when HTTP ext_proc processes local replies
An attacker can crash the Envoy proxy by triggering a local reply during an external processing filter interaction, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-30157?
CVE-2025-30157 is a medium-severity vulnerability in Envoyproxy Envoy, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Envoy is a cloud-native high-performance edge/middle/service proxy. Prior to 1.33.1, 1.32.4, 1.31.6, and 1.30.10, Envoy's ext_proc HTTP filter is at risk of crashing if a local reply is sent to the external server due to the filter's life time issue. A known situation is the failure of a websocket handshake will trigger a local reply leading to the crash of Envoy. This vulnerability is fixed in 1.33.1, 1.32.4, 1.31.6, and 1.30.10.
Weakness: CWE-460
Which versions are affected by CVE-2025-30157?
9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | All versions | 1.30.10 |
github.com/envoyproxy/envoy Go | All versions | 1.30.10 |
github.com/envoyproxy/envoy Go | From 1.31.0 | 1.31.6 |
github.com/envoyproxy/envoy Go | From 1.31.0 | 1.31.6 |
github.com/envoyproxy/envoy Go | From 1.32.0 | 1.32.4 |
github.com/envoyproxy/envoy Go | From 1.32.0 | 1.32.4 |
3 more packages
github.com/envoyproxy/envoy Go | From 1.33.0 | 1.33.1 |
github.com/envoyproxy/envoy Go | From 1.33.0 | 1.33.1 |
envoy Bitnami | All versions | 1.30.10, 1.31.6, 1.32.4, 1.33.1 |
Linux distribution packages (1)
istioctl openSUSE:Tumbleweed | All versions | 1.25.1-1.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2025-30157?
Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.30.10, 1.31.6, 1.32.4 or 1.33.1.
Is CVE-2025-30157 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30157 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2025-30157, GHSA-cf3q-gqg7-3fm9, openSUSE-SU-2025:14938-1.