# CVE-2025-30157: Envoy crashes when HTTP ext_proc processes local replies

> An attacker can crash the Envoy proxy by triggering a local reply during an external processing filter interaction, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** BIT-envoy-2025-30157, GHSA-cf3q-gqg7-3fm9, openSUSE-SU-2025:14938-1

## What is CVE-2025-30157?

CVE-2025-30157 is a medium-severity vulnerability in Envoyproxy Envoy, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Envoy is a cloud-native high-performance edge/middle/service proxy. Prior to 1.33.1, 1.32.4, 1.31.6, and 1.30.10, Envoy's ext_proc HTTP filter is at risk of crashing if a local reply is sent to the external server due to the filter's life time issue. A known situation is the failure of a websocket handshake will trigger a local reply leading to the crash of Envoy. This vulnerability is fixed in 1.33.1, 1.32.4, 1.31.6, and 1.30.10.

Weakness: CWE-460 (Improper Cleanup on Thrown Exception)

## Which versions are affected by CVE-2025-30157?

9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.30.10 |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.30.10 |
| `github.com/envoyproxy/envoy` | Go | From 1.31.0 | 1.31.6 |
| `github.com/envoyproxy/envoy` | Go | From 1.31.0 | 1.31.6 |
| `github.com/envoyproxy/envoy` | Go | From 1.32.0 | 1.32.4 |
| `github.com/envoyproxy/envoy` | Go | From 1.32.0 | 1.32.4 |
| `github.com/envoyproxy/envoy` | Go | From 1.33.0 | 1.33.1 |
| `github.com/envoyproxy/envoy` | Go | From 1.33.0 | 1.33.1 |
| `envoy` | Bitnami | All versions | 1.30.10, 1.31.6, 1.32.4, 1.33.1 |
| `istioctl` | openSUSE:Tumbleweed | All versions | 1.25.1-1.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-30157?

Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.30.10, 1.31.6, 1.32.4 or 1.33.1.

## Is CVE-2025-30157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30157 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30157 and fix it if it is affected.

What it is: CVE-2025-30157 is a medium-severity vulnerability in Envoyproxy Envoy, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30157 exists.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.30.10
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.30.10
- github.com/envoyproxy/envoy (Go): affected from 1.31.0; fixed in 1.31.6
- github.com/envoyproxy/envoy (Go): affected from 1.31.0; fixed in 1.31.6
- github.com/envoyproxy/envoy (Go): affected from 1.32.0; fixed in 1.32.4
- github.com/envoyproxy/envoy (Go): affected from 1.32.0; fixed in 1.32.4
- github.com/envoyproxy/envoy (Go): affected from 1.33.0; fixed in 1.33.1
- github.com/envoyproxy/envoy (Go): affected from 1.33.0; fixed in 1.33.1
- envoy (Bitnami): affected all versions; fixed in 1.30.10, 1.31.6, 1.32.4, 1.33.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30157/ (Markdown: https://insights.sbomify.com/CVE-2025-30157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30157
- OSV: https://osv.dev/vulnerability/CVE-2025-30157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30157/
Summaries are generated and may contain mistakes; the official description above is the record.
