CVE-2025-30159 Kirby vulnerable to path traversal of snippet names in the `snippet()` helper
Attackers can exploit dynamic snippet names to traverse directories, read arbitrary files, and execute PHP code on the server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30159?
CVE-2025-30159 is a medium-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `snippet()` helper or `$kirby->snippet()` method with a dynamic snippet name (such as a snippet name that depends on request or user data). Sites that only use fixed calls to the `snippet()` helper/`$kirby->snippet()` method (i.e. calls with a simple string for the snippet name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the snippets root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic snippet names, such as `snippet('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, Kirby maintainers have added a check for the snippet path that ensures that the resulting path is contained within the configured snippets root. Snippet paths that point outside of the snippets root will not be loaded.
Which versions are affected by CVE-2025-30159?
6 open source packages ship an affected version, including getkirby/kirby. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/kirby Packagist | All versions | 3.9.8.3 |
getkirby/kirby Packagist | All versions | 3.9.8.3 |
getkirby/kirby Packagist | From 3.10.0 | 3.10.1.2 |
getkirby/kirby Packagist | From 3.10.0 | 3.10.1.2 |
getkirby/kirby Packagist | From 4.0.0 | 4.7.1 |
getkirby/kirby Packagist | From 4.0.0 | 4.7.1 |
Products include Getkirby Kirby.
How do I fix CVE-2025-30159?
Upgrade getkirby/kirby to a fixed version for your release line: 3.9.8.3, 3.10.1.2 or 4.7.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-30159 being exploited?
There is no known exploitation of CVE-2025-30159 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-fw82-87p8-v6hp.