# CVE-2025-30160: Redlib allows a Denial of Service via DEFLATE Decompression Bomb in restore_preferences Form

> Attackers can cause denial of service in Redlib by submitting a DEFLATE decompression bomb to the restore_preferences form, exhausting memory.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-g8vq-v3mg-7mrg

## What is CVE-2025-30160?

CVE-2025-30160 is a high-severity denial of service vulnerability in redlib-org redlib, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Redlib is an alternative private front-end to Reddit. A vulnerability has been identified in Redlib where an attacker can cause a denial-of-service (DOS) condition by submitting a specially crafted base2048-encoded DEFLATE decompression bomb to the restore_preferences form. This leads to excessive memory consumption and potential system instability, which can be exploited to disrupt Redlib instances. This vulnerability is fixed in 0.36.0.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-30160?

2 open source packages ship an affected version, including redlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redlib` | crates.io | All versions | 0.36.0 |
| `redlib` | crates.io | All versions | 0.36.0 |

Products: Redlib Redlib.

## How do I fix CVE-2025-30160?

Upgrade redlib to 0.36.0 or later.

## Is CVE-2025-30160 being exploited?

There is no known exploitation of CVE-2025-30160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30160 and fix it if it is affected.

What it is: CVE-2025-30160 is a high-severity denial of service vulnerability in redlib-org redlib, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30160 in the wild and no public exploit code.

Affected packages and fixed versions:
- redlib (crates.io): affected all versions; fixed in 0.36.0
- redlib (crates.io): affected all versions; fixed in 0.36.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30160/ (Markdown: https://insights.sbomify.com/CVE-2025-30160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30160
- OSV: https://osv.dev/vulnerability/CVE-2025-30160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30160/
Summaries are generated and may contain mistakes; the official description above is the record.
