# CVE-2025-30165: Remote Code Execution Vulnerability in vLLM Multi-Node Cluster Configuration

> Attackers can execute arbitrary code on secondary nodes in multi-node vLLM deployments using the deprecated V0 engine via unsafe pickle deserialization.

- **Severity:** High 8.0 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 6 May 2025
- **Also known as:** GHSA-9pcc-gvx5-r5wm, PYSEC-2026-2017

## What is CVE-2025-30165?

CVE-2025-30165 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 6 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. In a multi-node vLLM deployment using the V0 engine, vLLM uses ZeroMQ for some multi-node communication purposes. The secondary vLLM hosts open a `SUB` ZeroMQ socket and connect to an `XPUB` socket on the primary vLLM host. When data is received on this `SUB` socket, it is deserialized with `pickle`. This is unsafe, as it can be abused to execute code on a remote machine. Since the vulnerability exists in a client that connects to the primary vLLM host, this vulnerability serves as an escalation point. If the primary vLLM host is compromised, this vulnerability could be used to compromise the rest of the hosts in the vLLM deployment. Attackers could also use other means to exploit the vulnerability without requiring access to the primary vLLM host. One example would be the use of ARP cache poisoning to redirect traffic to a malicious endpoint used to deliver a payload with arbitrary code to execute on the target machine. Note that this issue only affects the V0 engine, which has been off by default since v0.8.0. Further, the issue only applies to a deployment using tensor parallelism across multiple hosts, which we do not expect to be a common deployment pattern. Since V0 is has been off by default since v0.8.0 and the fix is fairly invasive, the maintainers of vLLM have decided not to fix this issue. Instead, the maintainers recommend that users ensure their environment is on a secure network in case this pattern is in use. The V1 engine is not affected by this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-30165?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.2 | 0.10.0 |
| `vllm` | PyPI | From 0.5.2 | 0.10.0 |
| `vllm` | PyPI | From 0.5.2 | 0.10.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-30165?

Upgrade vllm to 0.10.0 or later.

## Is CVE-2025-30165 being exploited?

There is no known exploitation of CVE-2025-30165 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30165 and fix it if it is affected.

What it is: CVE-2025-30165 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 6 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30165 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.2; fixed in 0.10.0
- vllm (PyPI): affected from 0.5.2; fixed in 0.10.0
- vllm (PyPI): affected from 0.5.2; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30165/ (Markdown: https://insights.sbomify.com/CVE-2025-30165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30165
- OSV: https://osv.dev/vulnerability/CVE-2025-30165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30165/
Summaries are generated and may contain mistakes; the official description above is the record.
