{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30166 exists.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.7.6 or later.","what":"CVE-2025-30166 is a low-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 8 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-30166 and fix it if it is affected.\n\nWhat it is: CVE-2025-30166 is a low-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 8 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30166 exists.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.6\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30166/ (Markdown: https://insights.sbomify.com/CVE-2025-30166/index.md)","id":"CVE-2025-30166","markdown":"https://insights.sbomify.com/CVE-2025-30166/index.md","name":"CVE-2025-30166","record":{"aliases":["GHSA-x82r-6j37-vrgg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore Admin UI","requires_auth":"high_privilege","summary":"Attackers with email access can inject HTML into admin-sent emails, potentially stealing session cookies and altering page content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"admin_classic_bundle","vendor":"pimcore"}],"cvss":{"score":1.8,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content. The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible. This vulnerability is fixed in 1.7.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore's Admin Classic Bundle allows HTML Injection","id":"CVE-2025-30166","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability","id":"CVE-2025-30167"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.6"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-x82r-6j37-vrgg"},{"ecosystem":"Packagist","fixed":["1.7.6"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-x82r-6j37-vrgg"}],"prev":{"headline":"Remote Code Execution Vulnerability in vLLM Multi-Node Cluster Configuration","id":"CVE-2025-30165"},"products":["admin-ui-classic-bundle"],"published":"2025-04-08","related":[{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.5,"headline":"Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls","id":"CVE-2023-49075","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":8.1,"headline":"Pimcore Host Header Injection in user invitation link","id":"CVE-2024-25625","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":6.9,"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":6.5,"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":6.3,"headline":"Pimcore vulnerable to disclosure of system and database information behind /admin firewall","id":"CVE-2024-41109","kev_date_added":null,"published":"2024-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["pimcore"]},"summary":"Attackers with email access can inject HTML into admin-sent emails, potentially stealing session cookies and altering page content.","url":"https://insights.sbomify.com/CVE-2025-30166/"}