# CVE-2025-30166: Pimcore's Admin Classic Bundle allows HTML Injection

> Attackers with email access can inject HTML into admin-sent emails, potentially stealing session cookies and altering page content.

- **Severity:** Low 1.8 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-x82r-6j37-vrgg

## What is CVE-2025-30166?

CVE-2025-30166 is a low-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 8 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content. The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible. This vulnerability is fixed in 1.7.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-30166?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.6 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.6 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2025-30166?

Upgrade pimcore/admin-ui-classic-bundle to 1.7.6 or later.

## Is CVE-2025-30166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30166 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30166 and fix it if it is affected.

What it is: CVE-2025-30166 is a low-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 8 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30166 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.6
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30166/ (Markdown: https://insights.sbomify.com/CVE-2025-30166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30166
- OSV: https://osv.dev/vulnerability/CVE-2025-30166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30166/
Summaries are generated and may contain mistakes; the official description above is the record.
