{"answers":{"affected":"3 open source packages ship an affected version, including jupyter_core and jupyter-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-30167 in the wild and no public exploit code.","fix":"Upgrade jupyter_core to 5.8.1 or later.","what":"CVE-2025-30167 is a high-severity vulnerability in jupyter_core, published on 3 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-30167 and fix it if it is affected.\n\nWhat it is: CVE-2025-30167 is a high-severity vulnerability in jupyter_core, published on 3 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-30167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyter_core (PyPI): affected all versions; fixed in 5.8.1\n- jupyter-core (PyPI): affected all versions; fixed in 5.8.1\n- jupyter-core (PyPI): affected all versions; fixed in 5.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30167/ (Markdown: https://insights.sbomify.com/CVE-2025-30167/index.md)","id":"CVE-2025-30167","markdown":"https://insights.sbomify.com/CVE-2025-30167/index.md","name":"CVE-2025-30167","record":{"aliases":["GHSA-33p9-3p43-82vq","PYSEC-2026-1477","UBUNTU-CVE-2025-30167","openSUSE-SU-2025:15272-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Jupyter Core library","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges on shared Windows systems by placing malicious configuration files in the shared ProgramData directory.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyter_core","vendor":"jupyter"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability","id":"CVE-2025-30167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Parse Server has an OAuth login vulnerability","id":"CVE-2025-30168"},"packages":[{"ecosystem":"PyPI","fixed":["5.8.1"],"introduced":["0"],"last_affected":[],"package":"jupyter-core","purl":"pkg:pypi/jupyter-core","source":"GHSA-33p9-3p43-82vq"},{"ecosystem":"PyPI","fixed":["5.8.1"],"introduced":["0"],"last_affected":[],"package":"jupyter-core","purl":"pkg:pypi/jupyter-core","source":"PYSEC-2026-1477"},{"ecosystem":"PyPI","fixed":["5.8.1"],"introduced":["0"],"last_affected":[],"package":"jupyter_core","purl":null,"source":"GHSA-33p9-3p43-82vq"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.8.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-jupyter-core","purl":"pkg:rpm/opensuse/python-jupyter-core\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15272-1"}],"prev":{"headline":"Pimcore's Admin Classic Bundle allows HTML Injection","id":"CVE-2025-30166"},"products":["jupyter_core"],"published":"2025-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-23","vendors":["jupyter"]},"summary":"Local attackers can escalate privileges on shared Windows systems by placing malicious configuration files in the shared ProgramData directory.","url":"https://insights.sbomify.com/CVE-2025-30167/"}