# CVE-2025-30167: Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

> Local attackers can escalate privileges on shared Windows systems by placing malicious configuration files in the shared ProgramData directory.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 23 Jan 2026
- **Also known as:** GHSA-33p9-3p43-82vq, PYSEC-2026-1477, UBUNTU-CVE-2025-30167, openSUSE-SU-2025:15272-1

## What is CVE-2025-30167?

CVE-2025-30167 is a high-severity vulnerability in jupyter_core, published on 3 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2025-30167?

3 open source packages ship an affected version, including jupyter_core and jupyter-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter_core` | PyPI | All versions | 5.8.1 |
| `jupyter-core` | PyPI | All versions | 5.8.1 |
| `jupyter-core` | PyPI | All versions | 5.8.1 |
| `python-jupyter-core` | openSUSE:Tumbleweed | All versions | 5.8.1-1.1 |

Products: Jupyter Jupyter Core.

## How do I fix CVE-2025-30167?

Upgrade jupyter_core to 5.8.1 or later.

## Is CVE-2025-30167 being exploited?

There is no known exploitation of CVE-2025-30167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30167 and fix it if it is affected.

What it is: CVE-2025-30167 is a high-severity vulnerability in jupyter_core, published on 3 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-30167 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter_core (PyPI): affected all versions; fixed in 5.8.1
- jupyter-core (PyPI): affected all versions; fixed in 5.8.1
- jupyter-core (PyPI): affected all versions; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30167/ (Markdown: https://insights.sbomify.com/CVE-2025-30167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30167
- OSV: https://osv.dev/vulnerability/CVE-2025-30167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30167/
Summaries are generated and may contain mistakes; the official description above is the record.
