CVE-2025-30168 Parse Server has an OAuth login vulnerability

Medium 6.9 Published Updated

Attackers can reuse authentication credentials across different Parse Server apps using specific third-party providers, leading to unauthorized account access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-30168?

CVE-2025-30168 is a medium-severity authentication bypass vulnerability in parse-community parse-server, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

Weakness: CWE-287

Which versions are affected by CVE-2025-30168?

5 open source packages ship an affected version, including parse-server and parse.

PackageAffectedFixed in
parse-server npmAll versions7.5.2
parse-server npmAll versions7.5.2
parse-server npmFrom 8.0.08.0.2
parse-server npmFrom 8.0.08.0.2
parse BitnamiAll versions8.0.2

How do I fix CVE-2025-30168?

Upgrade parse-server to a fixed version for your release line: 7.5.2 or 8.0.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-30168 being exploited?

There is no known exploitation of CVE-2025-30168 in the wild and no public exploit code.

Sources

Also known as BIT-parse-2025-30168, GHSA-837q-jhwx-cmpv.

Is CVE-2025-30168 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free