{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2025-30168 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 7.5.2 or 8.0.2.","what":"CVE-2025-30168 is a medium-severity authentication bypass vulnerability in parse-community parse-server, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-30168 and fix it if it is affected.\n\nWhat it is: CVE-2025-30168 is a medium-severity authentication bypass vulnerability in parse-community parse-server, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-30168 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 7.5.2\n- parse-server (npm): affected all versions; fixed in 7.5.2\n- parse-server (npm): affected from 8.0.0; fixed in 8.0.2\n- parse-server (npm): affected from 8.0.0; fixed in 8.0.2\n- parse (Bitnami): affected all versions; fixed in 8.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30168/ (Markdown: https://insights.sbomify.com/CVE-2025-30168/index.md)","id":"CVE-2025-30168","markdown":"https://insights.sbomify.com/CVE-2025-30168/index.md","name":"CVE-2025-30168","record":{"aliases":["BIT-parse-2025-30168","GHSA-837q-jhwx-cmpv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"none","summary":"Attackers can reuse authentication credentials across different Parse Server apps using specific third-party providers, leading to unauthorized account access.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server has an OAuth login vulnerability","id":"CVE-2025-30168","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":5,"n_references":6,"next":{"headline":"Admin Authorized File Upload and Execute PHP","id":"CVE-2025-30169"},"packages":[{"ecosystem":"Bitnami","fixed":["8.0.2"],"introduced":["0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2025-30168"},{"ecosystem":"npm","fixed":["7.5.2"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-837q-jhwx-cmpv"},{"ecosystem":"npm","fixed":["7.5.2"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-837q-jhwx-cmpv"},{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-837q-jhwx-cmpv"},{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-837q-jhwx-cmpv"}],"prev":{"headline":"Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability","id":"CVE-2025-30167"},"products":["parse-server"],"published":"2025-03-21","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["parse-community"]},"summary":"Attackers can reuse authentication credentials across different Parse Server apps using specific third-party providers, leading to unauthorized account access.","url":"https://insights.sbomify.com/CVE-2025-30168/"}