# CVE-2025-30168: Parse Server has an OAuth login vulnerability

> Attackers can reuse authentication credentials across different Parse Server apps using specific third-party providers, leading to unauthorized account access.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** BIT-parse-2025-30168, GHSA-837q-jhwx-cmpv

## What is CVE-2025-30168?

CVE-2025-30168 is a medium-severity authentication bypass vulnerability in parse-community parse-server, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-30168?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 7.5.2 |
| `parse-server` | npm | All versions | 7.5.2 |
| `parse-server` | npm | From 8.0.0 | 8.0.2 |
| `parse-server` | npm | From 8.0.0 | 8.0.2 |
| `parse` | Bitnami | All versions | 8.0.2 |

## How do I fix CVE-2025-30168?

Upgrade parse-server to a fixed version for your release line: 7.5.2 or 8.0.2.

## Is CVE-2025-30168 being exploited?

There is no known exploitation of CVE-2025-30168 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30168 and fix it if it is affected.

What it is: CVE-2025-30168 is a medium-severity authentication bypass vulnerability in parse-community parse-server, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-30168 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 7.5.2
- parse-server (npm): affected all versions; fixed in 7.5.2
- parse-server (npm): affected from 8.0.0; fixed in 8.0.2
- parse-server (npm): affected from 8.0.0; fixed in 8.0.2
- parse (Bitnami): affected all versions; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30168/ (Markdown: https://insights.sbomify.com/CVE-2025-30168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30168
- OSV: https://osv.dev/vulnerability/CVE-2025-30168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30168/
Summaries are generated and may contain mistakes; the official description above is the record.
