CVE-2025-30177 Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering
Attackers can inject Camel headers to trigger code execution via vulnerable components like camel-exec due to missing input filtering.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30177?
CVE-2025-30177 is a medium-severity code injection vulnerability in Apache Camel, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions.
This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6.
Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS.
Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction.
This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.
Weakness: CWE-164
Which versions are affected by CVE-2025-30177?
4 open source packages ship an affected version, including org.apache.camel:camel-undertow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-undertow Maven | From 4.10.0 | 4.10.3 |
org.apache.camel:camel-undertow Maven | From 4.10.0 | 4.10.3 |
org.apache.camel:camel-undertow Maven | From 4.8.0 | 4.8.6 |
org.apache.camel:camel-undertow Maven | From 4.8.0 | 4.8.6 |
Products include Apache Camel.
How do I fix CVE-2025-30177?
Upgrade org.apache.camel:camel-undertow to a fixed version for your release line: 4.10.3 or 4.8.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-30177 being exploited?
There is no known exploitation of CVE-2025-30177 in the wild and no public exploit code.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-vq4p-pchp-6g6v.