# CVE-2025-3018: SourceCodester Online Eyewear Shop Users.php sql injection

> Remote attackers can exploit SQL injection in the Users.php delete function to read or modify database contents.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Mar 2025
- **Updated:** 1 Apr 2025
- **Also known as:** GHSA-pw3g-hp64-xmx9

## What is CVE-2025-3018?

CVE-2025-3018 is a medium-severity SQL injection vulnerability in SourceCodester Online Eyewear Shop, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, was found in SourceCodester Online Eyewear Shop 1.0. Affected is an unknown function of the file /classes/Users.php?f=delete. The manipulation of the argument ID leads to sql injection. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-3018?

It affects 1 product.


Products: Oretnom23 Online Eyewear Shop.

## How do I fix CVE-2025-3018?

No fix has been published for CVE-2025-3018 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3018 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3018 exists.

## Other vulnerabilities in SourceCodester Online Eyewear Shop

- [CVE-2025-2846](https://insights.sbomify.com/CVE-2025-2846/): SourceCodester Online Eyewear Shop Registration Users.php registration sql injection (medium 6.9)
- [CVE-2025-2651](https://insights.sbomify.com/CVE-2025-2651/): SourceCodester Online Eyewear Shop admin exposure of information through directory listing (medium 6.9)
- [CVE-2024-5894](https://insights.sbomify.com/CVE-2024-5894/): SourceCodester Online Eyewear Shop manage_product.php sql injection (medium 6.9)
- [CVE-2023-2244](https://insights.sbomify.com/CVE-2023-2244/): SourceCodester Online Eyewear Shop GET Parameter update_status.php sql injection (medium 6.3)
- [CVE-2023-1969](https://insights.sbomify.com/CVE-2023-1969/): SourceCodester Online Eyewear Shop GET Parameter manage_stock.php sql injection (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3018 and fix it if it is affected.

What it is: CVE-2025-3018 is a medium-severity SQL injection vulnerability in SourceCodester Online Eyewear Shop, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3018 exists.

Affected product: SourceCodester Online Eyewear Shop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3018/ (Markdown: https://insights.sbomify.com/CVE-2025-3018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3018
- OSV: https://osv.dev/vulnerability/CVE-2025-3018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3018/
Summaries are generated and may contain mistakes; the official description above is the record.
