{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:zohoqengine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-30197 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:zohoqengine to 1.0.31.v4a_b_1db_6d6a_f2 or later.","what":"CVE-2025-30197 is a low-severity vulnerability in Jenkins Zoho QEngine Plugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-30197 and fix it if it is affected.\n\nWhat it is: CVE-2025-30197 is a low-severity vulnerability in Jenkins Zoho QEngine Plugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-30197 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:zohoqengine (Maven): affected all versions; fixed in 1.0.31.v4a_b_1db_6d6a_f2\n- io.jenkins.plugins:zohoqengine (Maven): affected all versions; fixed in 1.0.31.v4a_b_1db_6d6a_f2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30197/ (Markdown: https://insights.sbomify.com/CVE-2025-30197/index.md)","id":"CVE-2025-30197","markdown":"https://insights.sbomify.com/CVE-2025-30197/index.md","name":"CVE-2025-30197","record":{"aliases":["GHSA-2x3g-rr4w-4qrp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Zoho QEngine Plugin","requires_auth":"none","summary":"Attackers can observe and capture the QEngine API Key because the plugin fails to mask the form field, exposing sensitive credentials.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"zoho_qengine","vendor":"jenkins"}],"cvss":{"score":3.1,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-549","name":"Missing Password Field Masking"}],"description":"Jenkins Zoho QEngine Plugin 1.0.29.vfa_cc23396502 and earlier does not mask the QEngine API Key form field, increasing the potential for attackers to observe and capture it.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Zoho QEngine Plugin Displays Unmasked API Keys","id":"CVE-2025-30197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"ECOVACS Vacuum and Base Station Hard-Coded WPA2-PSK","id":"CVE-2025-30198"},"packages":[{"ecosystem":"Maven","fixed":["1.0.31.v4a_b_1db_6d6a_f2"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:zohoqengine","purl":null,"source":"GHSA-2x3g-rr4w-4qrp"},{"ecosystem":"Maven","fixed":["1.0.31.v4a_b_1db_6d6a_f2"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:zohoqengine","purl":"pkg:maven/io.jenkins.plugins/zohoqengine","source":"GHSA-2x3g-rr4w-4qrp"}],"prev":{"headline":"Jenkins AnchorChain Plugin Has a Cross-Site Scripting (XSS) Vulnerability","id":"CVE-2025-30196"},"products":["Jenkins Zoho QEngine Plugin"],"published":"2025-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["Jenkins Project"]},"summary":"Attackers can observe and capture the QEngine API Key because the plugin fails to mask the form field, exposing sensitive credentials.","url":"https://insights.sbomify.com/CVE-2025-30197/"}