# CVE-2025-30197: Jenkins Zoho QEngine Plugin Displays Unmasked API Keys

> Attackers can observe and capture the QEngine API Key because the plugin fails to mask the form field, exposing sensitive credentials.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** GHSA-2x3g-rr4w-4qrp

## What is CVE-2025-30197?

CVE-2025-30197 is a low-severity vulnerability in Jenkins Zoho QEngine Plugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Zoho QEngine Plugin 1.0.29.vfa_cc23396502 and earlier does not mask the QEngine API Key form field, increasing the potential for attackers to observe and capture it.

Weakness: CWE-549 (Missing Password Field Masking)

## Which versions are affected by CVE-2025-30197?

2 open source packages ship an affected version, including io.jenkins.plugins:zohoqengine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:zohoqengine` | Maven | All versions | 1.0.31.v4a_b_1db_6d6a_f2 |
| `io.jenkins.plugins:zohoqengine` | Maven | All versions | 1.0.31.v4a_b_1db_6d6a_f2 |

Products: Jenkins Zoho Qengine.

## How do I fix CVE-2025-30197?

Upgrade io.jenkins.plugins:zohoqengine to 1.0.31.v4a_b_1db_6d6a_f2 or later.

## Is CVE-2025-30197 being exploited?

There is no known exploitation of CVE-2025-30197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30197 and fix it if it is affected.

What it is: CVE-2025-30197 is a low-severity vulnerability in Jenkins Zoho QEngine Plugin, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-30197 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:zohoqengine (Maven): affected all versions; fixed in 1.0.31.v4a_b_1db_6d6a_f2
- io.jenkins.plugins:zohoqengine (Maven): affected all versions; fixed in 1.0.31.v4a_b_1db_6d6a_f2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30197/ (Markdown: https://insights.sbomify.com/CVE-2025-30197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30197
- OSV: https://osv.dev/vulnerability/CVE-2025-30197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30197/
Summaries are generated and may contain mistakes; the official description above is the record.
