CVE-2025-30202 Data exposure via ZeroMQ on multi-node vLLM deployment

High 7.5 Published Updated

Attackers with network access can read internal vLLM state or cause denial of service in multi-node deployments via exposed ZeroMQ sockets.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30202?

CVE-2025-30202 is a high-severity vulnerability in Vllm Vllm, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism across multiple hosts. Any client with network access to this host can connect to this XPUB socket unless its port is blocked by a firewall. Once connected, these arbitrary clients will receive all of the same data broadcasted to all of the secondary vLLM hosts. This data is internal vLLM state information that is not useful to an attacker. By potentially connecting to this socket many times and not reading data published to them, an attacker can also cause a denial of service by slowing down or potentially blocking the publisher. This issue has been patched in version 0.8.5.

Weakness: CWE-770

Which versions are affected by CVE-2025-30202?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.5.20.8.5
vllm PyPIFrom 0.5.20.8.5
vllm PyPIFrom 0.5.20.8.5

Products include Vllm Vllm.

How do I fix CVE-2025-30202?

Upgrade vllm to 0.8.5 or later.

Is CVE-2025-30202 being exploited?

There is no known exploitation of CVE-2025-30202 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-9f8f-2vmf-885j, PYSEC-2026-2016.

Is CVE-2025-30202 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free