# CVE-2025-30202: Data exposure via ZeroMQ on multi-node vLLM deployment

> Attackers with network access can read internal vLLM state or cause denial of service in multi-node deployments via exposed ZeroMQ sockets.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-9f8f-2vmf-885j, PYSEC-2026-2016

## What is CVE-2025-30202?

CVE-2025-30202 is a high-severity vulnerability in Vllm Vllm, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism across multiple hosts. Any client with network access to this host can connect to this XPUB socket unless its port is blocked by a firewall. Once connected, these arbitrary clients will receive all of the same data broadcasted to all of the secondary vLLM hosts. This data is internal vLLM state information that is not useful to an attacker. By potentially connecting to this socket many times and not reading data published to them, an attacker can also cause a denial of service by slowing down or potentially blocking the publisher. This issue has been patched in version 0.8.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-30202?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.2 | 0.8.5 |
| `vllm` | PyPI | From 0.5.2 | 0.8.5 |
| `vllm` | PyPI | From 0.5.2 | 0.8.5 |

Products: Vllm Vllm.

## How do I fix CVE-2025-30202?

Upgrade vllm to 0.8.5 or later.

## Is CVE-2025-30202 being exploited?

There is no known exploitation of CVE-2025-30202 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30202 and fix it if it is affected.

What it is: CVE-2025-30202 is a high-severity vulnerability in Vllm Vllm, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30202 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.2; fixed in 0.8.5
- vllm (PyPI): affected from 0.5.2; fixed in 0.8.5
- vllm (PyPI): affected from 0.5.2; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30202/ (Markdown: https://insights.sbomify.com/CVE-2025-30202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30202
- OSV: https://osv.dev/vulnerability/CVE-2025-30202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30202/
Summaries are generated and may contain mistakes; the official description above is the record.
