CVE-2025-30207 Kirby vulnerable to path traversal in the router for PHP's built-in server

Low 2.3 Published Updated

Attackers can determine file existence outside the document root via path traversal in Kirby's PHP built-in server router, affecting local development setups.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30207?

CVE-2025-30207 is a low-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

Weakness: CWE-23, CWE-22

Which versions are affected by CVE-2025-30207?

6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.

PackageAffectedFixed in
getkirby/cms PackagistAll versions3.9.8.3
getkirby/cms PackagistAll versions3.9.8.3
getkirby/cms PackagistFrom 3.10.03.10.1.2
getkirby/cms PackagistFrom 3.10.03.10.1.2
getkirby/cms PackagistFrom 4.0.04.7.1
getkirby/cms PackagistFrom 4.0.04.7.1

Products include Getkirby Kirby.

How do I fix CVE-2025-30207?

Upgrade getkirby/cms to a fixed version for your release line: 3.9.8.3, 3.10.1.2 or 4.7.1.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-30207 being exploited?

There is no known exploitation of CVE-2025-30207 in the wild and no public exploit code.

Sources

Also known as GHSA-9p3p-w5jf-8xxg.

Is CVE-2025-30207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free